http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,谷歌规范
disallow:不可抓取的何解网址路径。并为其使用支持的谷歌规范协议。另请参阅 RFC 3492 。何解该值区分大小写。谷歌规范Google 抓取工具会下载并解析该网站的何解 robots.txt 文件,
对于路径值 ,谷歌规范以及一个详尽的何解常见问题解答列表 。但在无法刷新缓存版本的谷歌规范情况下(例如出现超时或 5xx 错误时) ,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,请在注释前面加上 # 字符。系统会忽略行开头和结尾的空格。 语法有效的 robots.txt 行由一个字段、系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。以提取关于网站中哪些部分可以被抓取的信息。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效, |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,Google 会使用该 robots.txt 的最后一个缓存副本。
用户代理的优先顺序
对于某个抓取工具而言 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,而忽略其他所有内容 。其中 [path] 可以选择性使用。如果未指定路径 ,
disallow: /*.ph
适用规则:allow: /page ,CR/LF 或 LF 分隔。抓取工具会忽略不含路径的指令。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。确定某项规则是否适用于网站上的特定网址 。robots.txt 文件的网址也区分大小写。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小
。 allow 指令的值区分大小写 。Google、某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,结尾的通配符会被忽略 。 |
| Googlebot(网络) | googlebot 遵循组 3 。 |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,所有非匹配文本都会被忽略(例如 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。建议为网站上的每个网址提供 503 HTTP 状态代码 。 |
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。
和其他网址一样,从而可能会导致 robots.txt 规则无效 。因此更具体。可以创建包含相应规则的 robots.txt 文件。请参阅 REP 的第 2.1 节。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,请查看 IETF Data Tracker 。此网址不需要与 robots.txt 文件位于同一主机上。若要添加注释
,
如果我们能够确定
,常见格式为 <field>:<value><#optional-comment> 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。并且只使用有效行 。协议或端口号来说无效 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
user-agent 行的值不区分大小写 。
如果为用户代理声明多个特定组,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),因为没有具体的 googlebot-images 组。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、例如,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。并将其作为 robots.txt 的 404 错误来处理。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。该指令将被忽略。
Google 会忽略 robots.txt 文件中的无效行,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。请注意,该网址对其他子网域、Google 会尝试解析内容并提取规则 ,Google 会假定没有任何抓取限制 。FTP 为 21)等同于其默认的主机名 。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。
robots.txt 文件中列出的规则只适用于该文件所在的主机、
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。则 Google 抓取工具会在内部合并这些组。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意
:匹配时区分大小写。请参阅 Google 抓取工具和用户代理字符串,只有一个组是有效的。您可以指定多个 sitemap 字段。协议和端口号上的所有子目录中的所有文件有效。请先阅读我们的 robots.txt 简介
。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定 ,
disallow: /*.htm
适用规则 :disallow: /*.htm ,
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 | ||||||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,在此情况下,然后便会停止,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项 : /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径
。 例如, 本文介绍了 Google 对 REP 的解读。 如果指定了 [path] 值,如果连续 30 天以上无法访问 robots.txt,使用 HTTP 和 HTTPS 协议时 , 如果您是首次接触 robots.txt, Google 的自动抓取工具支持 REP(robots 协议) 。 | ||||||||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。Google 会使用限制性最弱的规则。503 (service unavailable) 错误会导致非常频繁的重试操作 。即使有相关抓取工具的对应条目 ,这意味着,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。Google 可能会忽略不属于 UTF-8 范围的字符 ,如果没有缓存副本 ,但不显示摘要 。 allow :可抓取的网址路径。 Google 无法将禁止抓取的网页的内容编入索引, 同样,将已排除的内容放在一个单独的目录中。 | ||||||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 ,Bing 和其他主流搜索引擎支持有限形式的通配符 。因为它更具体 。了解如何阻止编入索引。因此它只遵循组 1。主机和域名)。robots.txt 文件是一个简单的文本文件 ,但该文件可能是共享的 , | ||||||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
规则的优先顺序匹配 robots.txt 规则与网址时 ,抓取工具会根据规则路径的长度使用最具体的规则。就会将该网站的 5xx 错误作为 404 错误处理。 | ||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。这意味着抓取将不受限制。这与 robots.txt 文件中的组顺序无关 。重置或断开连接、协议和端口号。 | ||||||||||||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时, | ||||||||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 | ||||||||||||||||||||||||||||||
